Huddle Hub requires at least Microsoft Windows 7 SP1 (Service Pack 1) in order to run.


Please note also the following requirements:

- Microsoft .NET Framework 4.5 

- OpenGL 3.0 for your graphics card